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E-Scape ‘How To’ Guide       ver 1.0 

E-Scape version 2.13 and up. 

Operating E-Scape 

E-Scape can be operated in many ways. This guide shows some of the most common operations, and how to do them in two ways: 

1. Keyboard shortcuts. 

These are recommended for fastest operation (eg by teachers) - shown in column 2.  
 If no direct shortcut is available, the quickest way using menus or mouse is indicated. 

 

 

2. Pop-up menus operated by switches or keyboard 

These can be totally operated by switches or the PC keyboard, and aim to reduce physical work in various ways.  

For example, a series of menus may guide you through an operation, or audition music automatically, or present relevant options repeatedly. 

Using switches with E-Scape 

Switches can be connected to E-Scape in two ways:  

(a) Using a ‘switch interface’ connected via USB. 

This should be programmed to “press” the ‘1’, ‘2’, and ‘3’ keys on the PC keyboard. So, for example “pressing Switch 2” is the same as pressing the ‘2’ key. 

(b) Using MIDI notes 

These come from a MIDI keyboard, or other system like Soundbeam or Apollo.  These devices connect via USB - either directly, or using a ‘MIDI interface’ box. 

Operating menus with switches  

All menu operations start with the ‘Main Menu’, which is opened by 
pressing Switch 2 or the Spacebar. 

 

When open, menus are again operated with switches or keyboard: 

- Next item: Switch 2,   Spacebar,   DownCursor. 

- Select item: Switch 1,   Enter. 

- Previous item: Switch 3,   UpCursor. 

- Cancel menu: Esc,   Delete. 

‘Single Switch’ operation:  If E-Scape is set to use ‘single switch’, then Switch 2 and 3 should 
not be used - use only Switch 1 or Spacebar, and menus will scan by themselves.  

NB. If you do press switch 2 or 3 (eg as a helper) when in ‘single switch mode, then the 
menu will temporarily stop scanning until the next time it is opened. 

Keys are shown as labelled on PC keyboard.  

The ‘Shift’ key should only be used if indicated. 
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Ref. Operation Using Keyboard shortcuts  Using switches (pop-up menus) 

1. Performing  -  ‘Track conducting’ 

Performing means the user has live control – to varying 
degrees - over what happens when.  
This should not be confused with ‘Playing’. 

‘Track conducting’ means pressing switches or keys to play the next or previous phrase (‘segment’) in a track. 

Segments can be short (even one note), be a chord, or longer phrases – even a whole piece. 

Other switches or keys can change which track is used, so can change the palette of material  in use. 

1.1 Start ‘track conducting’ mode A Main menu -> Perform -> Conduct tracks 

1.21 Re-play last performance 
1
 `                 [usually above the ‘Tab’ key] Main menu -> Perform -> Replay last performance 

1.22 View last performance (open new score) P (to open menu)  
  -> Open a new Score on last performance 

Main menu -> Perform  
  -> Open a new Score on last performance 

1.3 Open conducting settings menu Ctrl- P Main menu -> Perform -> Conducting Set-up 

1.31 Set track conducting mode… Ctrl- P (to open menu) 
   -> Track Conducting mode 

Main menu -> Perform  -> Conducting Set-up 
  -> Track Conducting mode 

1.32 Set SWS (‘Scroll Within Segment’) mode Ctrl- P (to open menu) 
   -> Scroll Within Segment (SWS)? 

Main menu -> Perform  -> Conducting Set-up 
  -> Scroll Within Segment (SWS)? 

1.33 Create Segments 
- choosing length from menu 

Ctrl- P  (to open menu)   
   -> Create Segments  
   -> Create segments with length chosen from menu 

Main menu -> Perform -> Conducting Set-up  
  -> Create Segments… 
  -> Create segments - with a chosen length 

1.34 Create Segments 
- using length of selected notes 

Q Main menu -> Perform -> Conducting Set-up 
  -> Create Segments… 
  -> Create segments - using duration of selected notes 

1.35 Create Segments 
- by ‘tapping’ 

Ctrl-T Main menu -> Perform -> Conducting Set-up  
  -> Create Segments... 
  -> Create segments for this track - by tapping 

1.41 Set a ‘backing Score’ to play during performing  Ctrl- B  
2
 Main menu -> Perform -> Conducting Set-up  

  -> Assign a backing Score 

1.42 Set NO ‘backing Score’   (ie turn off) Ctrl- Shift- B Main menu -> Perform -> Conducting Set-up  
  -> Set NO backing Score 

1.5 WHILE in track conducting mode:  

1.51 Play next segment Spacebar,   RightCursor,   2 Switch 2 

1.52 Play previous segment  LeftCursor,   1 Switch 1  
3
 

                                                      

1
 The ‘Always record performances’ option needs to be set ‘on’ - see 7.41. 

2
  If one was previously chosen the shortcut will just assign this one again. To choose a different backing Score then do Ctrl- P (to open menu) -> Assign a backing Score. 

3
 If keyboard (‘A’) was used to start conducting (or if option is set to always allow backwards conducting with Sw 1). 
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1.53 Change track down DownCursor,   3 Switch 3 

1.54 Change track up UpCursor,   0 Switch 0 

1.55 STOP conducting A,   Enter,   1 Switch 1  
1
 

 

2. Playing This means the piece starts playing ‘as written’, ie with the timing fixed.  Not  to be confused with ‘Performing’. 

2.1 Play score - starting at beginning of page Enter Switch 1 

2.2 Play score - starting at current step cursor position 
2
 ;  N/A 

2.3 Play score ‘in context’  
   - ie  the time surrounding the selected note(s) 

X N/A 

2.4 Play current track - starting at beginning of page # N/A 

2.5 Play the selected notes 
  (in current track) 

Shift- S N/A 

2.6 STOP playing Enter,   Esc Switch 1 

 

3. Files etc  

3.11 Open Score  
  (from this user’s folder) 

Ctrl- O Main menu -> File  
  -> Open Score 

3.12 Open Public Score  
 

Alt- F  (to open menu)    
  -> Open Other..  -> Open Public Score 

Main menu -> File -> More File options  
  -> Open Public Score 

3.13 Open MIDI file Ctrl- Shift- O N/A 

3.21 Save Score  
  (to user’s folder) 

Ctrl- S Main menu -> File -> Save 

3.22 Save as…     
       (ie save Score with new name - to user’s folder)   

Ctrl- Shift- S Main menu -> File -> Save As… 

3.31 Change user Ctrl- U Main menu -> Other things  
  -> Change To Another User 

3.41 Open a new (empty) Score Ctrl- N Main menu  -> File -> New Score 

3.51 Choose a Score to view (from those already opened) Ctrl- F  (to open menu) Main menu  -> File 
  -> Select an open score 

                                                      

1
 If switch menu was used to start conducting (or if option is set to always stop with Sw 1). 

2
 The vertical red line - see 6.2. 
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4. Viewing and navigating   

4.11 Select track down / up  
  (when not performing) 

PageDown / PageUp  

4.21 View keyboard shortcuts Alt-U (open menu) -> User  
  -> Keyboard shortcuts info

1
 

 Main menu  -> Other Things 
  -> Show keyboard shortcuts

2
 

4.31 Zoom in x 2 Z  Main menu  -> Other Things 
  -> Window etc -> Zoom in x2 

4.32 Zoom out x2 Shift- Z Main menu  -> Other Things 
  -> Window etc -> Zoom out x2 

4.41 Scroll ½ page right ] Main menu  -> Other Things 
  -> Window etc -> Scroll right 

4.42 Scroll ½ page left [ Main menu  -> Other Things 
  -> Window etc -> Scroll left 

4.43 Reset page (and step cursor) to start of score  Home N/A 

 

5. Selecting and Editing  

5.11 Select all notes  
   (in the current track, on the current page) 

Ctrl- A  

   [or use mouse: Drag round notes] 

Main menu -> Edit 
  -> Choose Notes to Edit 
  -> Select ALL notes 

5.12 Select next note RightCursor  

   [Mouse: Click on note] 

Main menu -> Edit  
  -> Choose Notes to Edit  
  -> Select a note - forwards 

5.13 Select previous note LeftCursor 

   [Mouse: Click on note] 

Main menu -> Edit 
  -> Choose Notes to Edit 
  -> Select a note - backwards 

5.14 Select a group of notes Shift- RightCursor,  or 
Shift- LeftCursor 

   [Mouse: Drag round notes] 

Main menu -> Edit  
  -> Choose Notes to Edit 
  -> Add notes to block… 

5.21 Transpose selected notes up one UpCursor  Main menu -> Edit  
  -> Repeat Make Pitch Higher  

                                                      

1 If mouse or keyboard is used, then shortcuts are shown in a single window. You can then use the keyboard: PageUp / PageDown to scroll; Alt- F4 to close. 

2 If switches are used, then shortcuts will be shown in a series of windows, with switch control. 
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5.22 Transpose selected notes down one DownCursor Main menu -> Edit  
  -> Repeat Make Pitch Lower 

5.23 Transpose selected notes up by interval (menu) Shift- UpCursor Main menu -> Edit -> MORE edit options  
  -> Make pitch higher (menu) 

5.24 Transpose selected notes down by interval (menu) Shift- DownCursor Main menu -> Edit -> MORE edit options  
  -> Make pitch lower (menu) 

5.31 Move selected notes forwards one ‘snap’ 
1
 Ctrl- RightCursor Main menu -> Edit -> MORE edit options  

  -> Move note (menu)  
  -> Move forwards ¼ beat (snap) 

5.32 Move selected notes backwards one ‘snap’ Ctrl- LeftCursor Main menu -> Edit -> MORE edit options  
  -> Move note (menu)  
  -> Move backwards ¼ beat (snap 

5.41 Change length of selected notes E  (open Edit menu)  

  -> Change Duration 

Main menu -> Edit -> Change duration 

5.51 Make selected notes louder by… V Main menu -> Edit -> Make louder 

5.52 Make selected notes softer by… Shift- V Main menu -> Edit -> Make softer 

5.53 Set loudness of selected notes Alt- V Main menu -> Edit -> MORE Edit options 
  -> Set loudness (velocity) 

5.61 Set tempo higher Shift- E  (to open menu) 
  -> Choose higher tempo 

Main menu -> Edit -> MORE Edit options  
  -> Increase Tempo 

5.62 Set tempo lower Shift- E  (to open menu) 
  -> Choose lower tempo 

Main menu -> Edit -> MORE Edit options  
  -> Decrease Tempo 

5.71 Add another track O (to open menu) -> Add another track Main menu -> Other things -> Add another track 

5.81 Choose Instrument for track I -> select from menus 

                    (will audition if using PC keyboard) 
Main menu -> Other things -> Choose Instrument 
   -> select from menus 
 

                                                      

1
 Snap is the smallest time interval in use, typically 1/8 beat (1/32 note / demisemi-quaver). This can be altered – see 7.3. 
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6. Entering notes You can enter notes in two ways:   

1) Recording live in ‘real-time’ from a MIDI instrument.    

2) Note by note using ‘step entry’. 

6.1 (1) Recording live  

6.11 Start live recording into current track 
[NB. Recorded notes will be added to the track, starting 
at the step position 6.2] 

Alt- R Main menu -> Enter Notes  
  -> MORE  
  -> Record… 

6.12 Start live recording to create a NEW Score 
 [NB. The new score will have a track for each player / 
MIDI channel] 

Alt- F (to open menu)  
  -> Create Score  
  -> by Real-time recording 

Main menu -> File  
  -> More File options  
  -> MIDI Record…  

 (2) Step Entry ‘Step entry’ means that you add each note one by one, by specifying three things: (a) position, (b) length, (c) pitch. 

6.2 (a) Position of ‘Step cursor’ To specify the position of a new note, you move the ‘step cursor’ (red vertical line).  Notes will be added at this 
position.    NB. The step cursor automatically moves to the end of each newly added note. 

6.21 Move step cursor anywhere. Drag with mouse within the ruler at bottom of page. Main menu -> Enter Notes -> MORE  
  -> Move cursor position… 

6.22 Move Step cursor by ‘step length’    [ = “add rest” ] - Main menu -> Enter Notes -> ‘Add Rest’ 

6.23 Move Step cursor right by ‘snap’ length 
1
 .        (full stop) Main menu -> Enter Notes  

  -> More -> Move cursor… 
  -> Repeat Go Forwards by ¼ beat (snap) 

6.24 Move Step cursor left by ‘snap’ length ,        (comma) Main menu -> Enter Notes  
  -> More -> Move cursor … 
  -> Repeat Go Backwards by ¼ beat (snap) 

6.25 Move Step cursor right one bar > Main menu -> Enter Notes  
  -> More -> Move cursor... 
  -> Repeat Go to Next Bar - Forwards 

6.26 Move Step cursor left one bar < Main menu -> Enter Notes  
  -> More -> Move cursor... 
  -> Repeat Go to Next Bar - Backwards 

                                                      

1
 See 7.34 
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6.3 (b) Step Length To specify the length of a new note, you can set a ‘step length’ (eg 1/2 beat, semi-quaver, 1/8
th
 note).  

All notes added will then have this length. 

6.31 Choose Step Length from menu… D Main menu -> Enter Notes 
  -> Choose Step Length… 

6.32 4 beats   (Semi-breve / Whole-note) Alt- 1   -> 4 beats 
1
 

 2 beats              (Minim /  Half-note) Alt- 2   -> 2 beats 

 1 beat     (Crotchet / Quarter-note) Alt- 3   -> 1 beat 

 1/2  beat         (Quaver / Eighth-note) Alt- 4   -> 1/2 beat 

 1/4 beat         (Semi-quaver / Sixteenth-note) Alt- 5   -> 1/4 beat 

 1/8 beat          (Demisemi-quaver / Thirtysecond-note) Alt- 6   -> 1/8 beat 

6.33 3 beats       (dotted Minim / dotted Half-note) Alt- 7   -> 2 + 1 beat 

 1- ½ beats        (dotted Crotchet / dotted Quarter-note) Alt- 8   -> 1 + 1/2 beat 

 3/4 beat  (dotted Quaver / dotted Eighth-note) Alt- 9   ->1/2 + 1/4 beat 

 3/8
th
 beat   (dotted Semi-quaver / dotted Sixteenth-note) Alt- 0   -> 1/4 + 1/8 beat 

6.4 (c) Pitch / Adding notes  To specify the pitch of a new note, you can add a new note in various ways:  
(i) play on a MIDI keyboard etc (‘MIDI step recording’ mode). 
(ii) choose pitch from a menu. 
(iii) start off with the pitch of the previous note, then change it.   [NB. Switch users can use methods ii or iii]. 

6.41 Start ‘MIDI step recording’ mode  
  [display then shows red] 

R Main menu -> Enter Notes  
  -> MORE  
  -> Turn on MIDI note entry 

6.42 Exit ‘MIDI step recording’ 
  [display then shows usual pink] 

R Main menu -> Enter Notes  
  -> MORE  
  -> Turn off MIDI note entry 

6.43 Add new note – choosing pitch from menu K Main menu -> Enter Notes  
  -> Add note [Pitch chosen from menu] 

2
 

6.44 Add new note - with pitch of previous note + N/A 

6.45 Add new note - with pitch of previous note, followed by 
auditioning 

= Main menu -> Enter Notes  
  -> Add note… 

                                                      

1
 Depending on the option set, this menu could instead display note length in more advanced terms, eg “Semi-breve (whole note)” 

2
 This option will be present in the menu instead of ‘Add Note..’ , if the ‘Pitch Entry’ mode is set to do so. See Settings menu (7.1). 
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7. ADVANCED FUNCTIONS  

7.1 Open main Settings menu S   (to open Settings Window), then press Spacebar Main menu  -> Other Things  -> Settings 

7.2 Open notepad for Score Ctrl- Shift- T  

7.3 Composing  

7.31 Choose scale to use for notes Alt- S (to open menu)  
  -> Choose Scale to work in 

Main menu  -> Other Things  -> Settings  
 -> Choose Scale to compose in 

7.32 Change pitch up chromatically (not within scale) Ctrl- UpCursor  Main menu  -> Edit  -> MORE edit options  
  -> Make pitch higher (menu) 

7.33 Change pitch down chromatically (not within scale) Ctrl- DownCursor Main menu  -> Edit  -> MORE edit options  
  -> Make pitch lower (menu) 

7.34 Change time ‘snap’ (for moving step cursor or notes) U (to open menu)  -> Time snap… Main menu  -> Other things  -> Utilities  -> Time snap… 

7.41 Set ‘Always record performances’ 
1
  on / off Alt- P (to open menu)  

  ->  Always Record Performances -> On / Off 
N/A 

7.5 While in conducting mode  

7.51 Reset track 1, 2, …9, 10  to beginning Alt- Shift- 1, Alt- Shift- 2, …Alt- Shift- 9, Alt- Shift- 0 N/A 

7.52 ‘Pause’ on 
2
 for track, 1, 2, …9, 10, 11 F1, F2,… F9, F10, F11   N/A 

7.53 ‘Pause’ on for all tracks F12 N/A 

7.54 ‘Pause’ off for track, 1, 2, …10, 11 Shift- F1, Shift- F2, …Shift- F10, Shift- F11 N/A 

7.55 ‘Pause’ off for all tracks Shift- F12 N/A 

7.56 Select next segment (without playing) in current track Alt- RightCursor N/A 

7.57 Select previous segment (without playing) in current 
track 

Alt- LeftCursor N/A 

7.58 Select previous segment (without playing) in  
track 1, 2, …8, 9, 10 

Alt- 1, Alt- 2, …Alt- 8, Alt- 9, Alt- 0 N/A 

                                                      

1
  See 1.2 

2
 ‘Pause on’ means the track will not respond to its conducting switch. 
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Using the drop-down menus 

If you use a mouse etc, you can also use the drop-down menus at the top of the Score window.  

These usually have a few more options than the pop-up menus, and can have sub-menus. 

 

These menus can also be opened and operated using the keyboard only:- 

 

1. Opening menus via shortcuts: 

Alt- F File menu 

Alt- E Edit menu 

Alt- Y Play menu 

Alt- N Enter Notes menu 

Alt- P Perform menu 

Alt- S Score menu 

Alt- T Track menu 

Alt- W Window menu 

Alt- U User / Set-up menu 

 

2. Navigating within menus: 

- Next item:    Switch 2,   DownCursor,   Spacebar 

- Select item or open sub-menu:  Switch 1,   Enter 

- Previous item:    Switch 3,   UpCursor 

- Open sub-menu:   RightCursor 

- Back to previous menu from sub-menu: LeftCursor,   Esc 

- Cancel (top level menu):   Esc 

 


